www.beck-ipc.comwww.beck-ipc.com  | ImprintImprint
FAQFAQ  | SearchSearch  |

GM01 to GM04 Migration

Questions and discussions about IPC@CHIP® hardware addons (e.g. FK61-WL01)

GM01 to GM04 Migration

Postby rklan » 10.09.2013, 10:08

I am a user of the GM01 GSM/GPRS Modem, and this is working fine.
Now I like to upgrade to the GM04 module... Yesterday I received a sample, and it fits nice, mechanically.
Now I have a problem using the GM04.
It is not responding at all. It returns the gmInit() with error -103.
I downloaded the lastest GMLIB and re-compiled my program.
Still the same issue. I think the GM04 is not turned on by my hardware. My hardware uses the IGNN method, which is , unfortunately not supported.
But from the manual I understand that the GM04 powers automatically, when power is applied to it.
The GM01 is working perfectly with the hardware.
I don't understand why this new module is NOT responding, while it should turn on automatically.
Has anyone experience with the migration from GM01 to the GM04 module?
Does it have another default baudrate or so?

Regards Remco

Re: GM01 to GM04 Migration

Postby rklan » 10.09.2013, 15:08

Some extra info: I found out why my new GM04 module was not working, I connected the RESET_IN in the existing hardware, and therefore the module was not working. Now I get a responce, but it seems that the FWlib is not supporting this module, but it should....


GMLIB version V1.62
Power on GM0x (IGN method)................-................
GM04 (G30) found
Error: Modem is not a GM0x 352288031760510
Logon failed: -134

Could not initialize modem device: -134

can anyone help?

Re: GM01 to GM04 Migration

Postby Andre Pribil » 16.09.2013, 10:48


this GM04 sample currently requires a special GMLIB version.
Problem solved via direct Email contact.

André Pribil
Software Development
Beck IPC GmbH

Return to Hardware Addons

Who is online

Users browsing this forum: No registered users and 1 guest