www.beck-ipc.com
www.beck-ipc.comwww.beck-ipc.com  | ImprintImprint
FAQFAQ  | SearchSearch  |
RegisterRegister   |LoginLogin

Cannot execute bex on DB150

Questions and discussions about the operating system RTOS-LNX and the corresponding C-LIB.

Cannot execute bex on DB150

Postby petr__m » 17.08.2016, 17:16

Hello,

Our SW was sucessfully compiled and maintained under x86 (Paradigm compiler) and PPC (One Workbench) platform. Now we are trying to release it under SC1x5 platform, for test purposes we got DB150 development board. Thanks to backward compatability of RTOS-LNX, it shouldn't take much effort.

After two days of solving cross platform issuses, the build in One WorkBench is able to produce bex file. The problem is, that we can't execute it on board. After copying bex via FTP, and running the application in command line, nothing happens. There is no error message. Command "tasks" doesn't indicate running process, command "errors" doesn't return anything.

We try to build proximity/ambient demo and hello world program with the same technique as our application (the same project settings in One Workbench) and both of them produce working bex file. We can see it in tasks list and it produces text output on console.

We placed printf rigth after main method beginning and commented out all other code in it, so the rest of our application in binary executable is death meat - but still no luck, ther's no message in console after running application. In our opinion something must fail in very early phase of execution.

Our bex has about 600kB. In comparison to examples it is much bigger. Anyway in other beck platforms our application executable is similar in size and we don't experience any troubles.

Remote debug in One Workbench shows segmentation fault right after the start, but the source is unknown (no symbols, no call stack) - it's probably in shared library.

Is it possible, that the size of bex could cause such behavior? Can you please give me some advice?

@CHIP-RTOS-LNX SC1x5 V01.04 Beta, Build: Jul 5 2016 09:54:28
ONE - Workbench for IPC@CHIP® Version: 2.5.2.Beta Build ID: 20160707-1000

Petr Muchna
Attachments
gdb_log.txt
(8.27 KiB) Downloaded 317 times

It sounds like your One-Workbench is configured to produce a program for the RTOS-PPC targets. They use the *.bex extension.

For the RTOS-Linux I would expect to see a *.elf type executable.
Jack Gatrost
Software Development
Beck IPC GmbH

Re: Cannot execute bex on DB150

Postby petr__m » 18.08.2016, 16:54

Thanks for your hint. In One-Workbench we are using SC1x5 toolchain, which produces files with .bex extension. Inner structure of these files is ELF, it fits according to RTOS-LNX programming notes, see http://www.beck-ipc.com/files/api/sc145 ... gramming_2. As I stated in my previous post, the configuration of toolchain isn't probably the issue, we managed to build and test two "Hello world" projects with the same (toolchain default) settings as our application and they work fine.

Petr Muchna

This post has been moved to a more appropriate topic.
Michael G. Etairidis
Software Development
Beck IPC GmbH

The details of this problem have been clarified via direct email contact.

The problem will be solved with RTOS-LNX V1.05 Beta.

Regards,
André Pribil
Software Development
Beck IPC GmbH

Return to RTOS-LNX


Who is online

Users browsing this forum: No registered users and 1 guest


cron